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Importing purchase orders
Importing purchase orders
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Written by Sara Jaffer
Updated over a week ago

When you first start using Inventory Planner Essentials, you may want to import your existing purchase orders that are awaiting inventory due to arrive at a future date.

Importing your existing open purchase orders ensures that Inventory Planner considers incoming inventory when making purchase order recommendations.

How to import outstanding purchase orders

Go to the Purchase Order list using the top navigation bar, then click the Import POs button in the page footer. This will take you through four steps to create each purchase order:

  1. Create and upload a file

  2. Specify additional PO details

  3. Import

  4. View the results

Create and upload the file

Create a separate CSV or XLS file for each purchase order you wish to import. This file should contain one row per order line item, with the first row containing the column headers: SKU and Quantity.

  • SKU is the variant identifier and must match the SKU of a variant synced from your Shopify store.

  • Quantity is the number of units outstanding on the PO. Note that if items have already been received into stock (and are already reflected in Shopify’s inventory level), the quantity should specify the remaining quantity to be received, not the total ordered quantity.

Once you have uploaded the file, move to the next screen to specify the purchase order details.

Specify PO details

Here, you can specify details relating to the purchase order:

  • Select the vendor from the dropdown menu. Learn more about creating vendors here.

  • Select the expected date from the date picker. This should be the date that inventory is expected to arrive into stock.

  • If required, enter the order reference #. If left blank, this will be generated automatically.

  • If required, enter the extra reference #. This is usually the vendor’s order number.

Additional details (such as item cost prices and vendor references) will be taken from the Variant catalog.

Import

Click Import to start the import. Once started, the process may take a couple of minutes.

Once complete, you’ll be directed to the Results screen.

View the results

If the import is successful, the results screen will display the purchase order reference. Click the reference number to view or edit the order, or click + New import to repeat the process to create additional orders.

If an error occurred, the purchase order will not be created and the results screen will display any relevant error message. Click View errors for further details on which rows failed validation.

Potential errors

Error

Cause

Failed to find variant

The SKU does not exist in Inventory Planner. Check that the SKU in your file is correct and that the variant has been synced from Shopify.

Non-numeric quantity

A value in the quantity column is not a number, e.g. contains alpha characters or symbols.

Empty SKU

The SKU field is empty.

Invalid quantity

The quantity field is empty.

Correct any errors in the import file before reattempting the import.

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